Etrieve Issues
Incident Report for Okanagan College - IT
Resolved
This incident has now been resolved.
Posted Sep 10, 2024 - 15:54 PDT
Investigating
We have received reports of PDF upload failures within Etrieve Forms, as well as issues preventing changes in Form Builder from being saved. Our IT team is actively collaborating with the vendor to resolve these problems.
Posted Sep 10, 2024 - 14:52 PDT
This incident affected: Etrieve Central (Softdocs).