The Concord Parking website is currently unavailable.

Incident Report for Okanagan College - IT

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 16:37 PDT

Investigating

The Concord Parking website is currently unavailable. We are actively working with the vendor to troubleshoot the issue. Further updates will be provided as they become available.
Posted Sep 16, 2025 - 15:38 PDT
This incident affected: Other.